RobustInternetSpeedBooster_Overview

Robust Speed Booster

Overview
This chapter offers an introduction to Robust Internet Speed Booster, a brief overview, system requirements, the installation procedure, information about software updates, and instructions for giving feedback to Robust. Inc.


RobustInternetSpeedBooster_Why SB

Robust FTP

Why Robust Internet Speed Booster?

Robust Internet Speed Booster easily solves two of the well known Internet problems:

1. Undesirable disconnections
2. Slow Internet connection performance

Robust Internet Speed Booster can prevent TCP/IP protocols data transfer from being fragmented. If applied it can boost your Internet connection performance 2 to 4 times. Robust Internet Speed Booster’s Ping option prevents you from being disconnected by your ISP (Internet Service Provider) Most ISPs have inactivity timeout, which means they can disconnect you after a fixed time of modem inactivity. This could happen if you leave your computer on for a while or while you are reading something on the Internet and before you have finished you see the disconnect dialog box appear on your screen. Robust Internet Speed Booster will prevent those undesirable disconnections by sending and receiving a data package as a Ping interval at a fixed time you set.
Internet Speed Booster includes a very intuitive and simple to operate user interface and a comprehensive help file.


RobustInternetSpeedBooster_Highlights

Highlights?
  • Supports Windows 95/98/Me/NT/2000/XP.
  • Prevents you from being disconnected by your ISP
  • ISB has a built in Automatic Ping mode.
  • The user has full control over the Ping Interval, Ping Host and Ping Sound.
  • Includes easy registry backup.
  • The user can set MaxMTU, RWIN, TTL, Session keep Alive, PMTU and NDI cache.
  • ISB has a manual mode to configure Dial-UP and LAN settings.
  • Also ISB has two automatic modes to configure Dial-UP and LAN settings.
  • The default Widows settings can be easily restored.
  • Supports all software and hardware adapters.


RobustInternetSpeedBooster_System Requirements

System Requirements?

The minimum requirements for using Robust Internet Speed Booster are:

  • An Intel 386, 486, or Pentium processor.
  • Windows 95, 98, 2000, ME, NT or XP.
  • 16 MB RAM.
  • Any type of Internet connection.


RobustInternetSpeedBooster_Installing

Installing Robust Internet Speed Booster?

The installation of Robust Internet Speed Booster is the same for new users, those who are upgrading from a previous version of Robust Internet Speed Booster, and those who are replacing an evaluation version with a purchased version.

To install Robust Internet Speed Booster from a downloaded file:

1. | Double-click the file you downloaded. (rwsisb30.exe)
2. | Follow the directions on your screen.

To install Robust Internet Speed Booster from a CD-ROM:

1. | If you already have a previous version of Robust Internet Speed Booster on your system, make sure you are not running the application.
2. | Insert the Robust Internet Speed Booster CD-ROM into a CD-ROM drive.
3. | If the CD-ROM does not automatically display a "Welcome" screen, click the Start button and select Run.
4. | Enter the CD-ROM drive letter followed by autorun. For example: d:autorun.
5. | Follow the instructions on your screen.


RobustInternetSpeedBooster_Interfaces

Interfaces for Windows 9x, 2000, ME, NT or XP?

The interface is made for easy navigation using tabs. All tabs accessible from the main window.


RobustInternetSpeedBooster_Feedback

Getting Updates & Giving Feedback?

Robust.ws frequently makes patches and upgrades available on our Web site. For the latest version information, please visit www.Robust.ws.

We welcome your feedback on Robust Internet Speed Booster. Please e-mail any comments and suggestions to feedback@Robust.ws.


RobustInternetSpeedBooster_Uninstalling

Uninstalling?

The uninstall function can remove all files associated with Robust Internet Speed Booster from your PC.

To uninstall Internet Speed Booster:

1. | Click the Start button and select Control Panel --> Add/Remove Programs --> Robust Internet Speed Booster .
2. | When prompted, choose Robust Internet Speed Booster Uninstall.
3. | Follow the on-screen instructions to uninstall Robust Internet Speed Booster .


RobustInternetSpeedBooster_Configuration Options

Configuration Options

Robust Internet Speed Booster can improve the internet connection speed if you are using any of the following connections (Dialup, DSL, Cable, LAN etc.). Due to the fact that there are a lot of different hardware vendors and because each computer is a little bit different from the other. It’s very hard to configure your connection automatically.

Robust Internet Speed Booster has provided three automatic optimization modes to improve your internet connection speed. They should be tried out to see which one suits your computer configuration best.
The manual optimization mode should be tried if the automatic modes don’t satisfy the user. Various settings should be tried. MTU (Maximum Transmission Unit), RWIN (Receive Window), TTL (Time To Live), Session Keep Alive, General Settings, NDI Cache.


RobustInternetSpeedBooster_PingConfiguration

Ping Configuration

The following three parameters can be set manually:

Ping Host: Write the host that will handle the ping in the text box. The IP address also can be used.
Ping Interval: Choose the wanted interval between every ping (recommended: 5 minutes).
Play sound at ping: If this parameter is checked then the program will play a sound every time a ping occurred.


RobustInternetSpeedBooster_MTU Term

MTU(Maximum Transmission Unit)

What exactly is this mystical MTU anyway? The Maximum Transmission Unit of a network is the greatest amount of data or "packet" size that can be transferred in one physical frame on that network. This packet also contains the header and trailer information, which are kind of like addresses for each packet that are required by the routers on the network. Fragmentation will occur if a packet is sent across a network that has an MTU smaller than the packet's frame length. This will lead to reduced performance levels as fragments need to be reassembled. When a connection is opened between two computers, they must agree on an MTU.Windows uses this default packet size to negotiate with. This is done by comparing MTUs and selecting the smaller of the two. If this value is set too high for the routers to handle between the two computers, then this info is fragmented into a packet size that the router can handle. This negotiation takes some time and can double the time it takes to send a single packet. Therefore; if the ISP uses an MTU then every time a connection is started, Windows must adjust to an acceptable MTU. By setting this value manually, you can greatly reduce the amount of work that Windows must do to negotiate and reach an acceptable MTU.

With Windows 95, all versions, including OSR2, have a "hidden" default for MTU set in the registry at 1500. This is appropriate for LAN's and all Ethernet connections, but can be very inefficient when using a PPP dialup connection. This has now been recognized by Microsoft and corrected in Windows 98 to some extent. It's really quite simple. Any intermediary IP routers encountered on the Internet which are set to an MTU less than 1500, when they handle your TCP/IP request, will often fragment an MTU, breaking it up into smaller units, before sending it out on the network.

MTU is normally set in conjunction with MSS, the Maximum Segment Size, and RWIN, the TCP Receive WINdow. MSS is the largest segment of TCP data that the winsock is prepared to receive on that connection. MSS must be smaller than MTU by at least 40 bytes, the size of the header and trailer information. RWIN determines how much data the receiving computer is prepared to receive. If RWIN is set too large it will result in greater loss of data if a packet is lost or damaged. If it is set too small (e.g. 1x MSS), transmission will be very slow. Normally RWIN is set to either 4x, 6x or 8x MSS. Here's a simple analogy. TCP/IP takes an e-mail letter (or web page) and cuts it into nice neat squares (packets). It puts each piece in an envelope with the address (header) of where it’s going for the routers to send it along its way. Then all the letters are delivered to your mailbox. So...

MSS = the size of each cut square of paper
MTU = the size of the envelope (which must be slightly bigger than the square of paper)
RWIN = the size of the mailbox which "receives" the letters

The maximum speed of TCP/IP transfers through a SLIP (Serial Line Protocol) or PPP (Point to Point Protocol) connection is, first and foremost, limited by the speed of the modem. In an ideal world, for an already compressed file, you should be able to get 3.2 Kbytes/sec transfers with a 28.8 Kbps (kilobits per second) connection; 2.7 Kbytes/sec with a 24 Kbps connection; 1.6 Kbytes/sec with a 14.4 Kbps connection; etc. Roughly speaking, each one Byte/sec of delivered TCP data rate requires 9 bps of modem connect rate. Note that newer modems allow for much greater compression of certain types of files. Text files and html files can often be compressed by a factor of 2x or 3x, effectively doubling or tripling the speeds mentioned above.

The data transfer speeds mentioned above are the ideal speeds one can achieve, but this is often thwarted by fragmentation which may occur in the transmission of packets of data. As you visit various web sites, you may encounter routers on the download path with an IP default MTU of only 576 bytes. Thus, if you use the Windows default MTU settings of 1500, this can often result in packet fragmentation slowdown (since you are trying to use TCP segments (MSS) larger than 536 bytes.) Avoiding fragmentation has a major effect on file download speed, whether we are talking about html and image files from the web or straight text data bits in your e-mail program.

An MTU of 576 used to be the most common MTU setting in use and was generally referred to as the "Internet Standard". However modern routers are more often than not set to 1500 as an MTU. So why use a smaller MTU? Well in an ideal world, you would not do that any longer. You'd use 1500 and be done with it. However, there is still a good deal of Internet congestion out there, more than ever, really. And with this congestion, packets of data are "dropped" and as a result need to be retransmitted. Simply put, it takes just over 1/3 as long to retransmit a smaller packet, say 576 bytes in size, than it does to retransmit one 1500 bytes in size.

So in summary, whether you’re ISP, the site you are going to. Or the intermediary routers involved have any 576 MTU settings or not, setting your own computer's MTU to a setting smaller than 1500 (like 576) will often result in faster download speeds for those using Dialup connections.
Download speeds for Broadband connections like cable DSL, and Satellite. Broadband connections work best with an MTU setting of 1500; however they work better with significantly higher RWIN settings than Dialup .So how can you avoid fragmentation during TCP data transfers? Very simple... you can limit the MTU of your TCP/IP request to a smaller or optimum size. Most people that are using Windows 95 and the Win95 Dialup Adapter, which employs the winsock.dll in C:\Windows and wsock32.dll file in C:\Windows\System (wsock32n.dll belongs to MSIE). You are probably using a PPP dialup connection which most ISP's use these days. All versions of Windows 95 are set up by default to request a maximum MTU of 1500. You can, however, change that default setting. And, it turns out, depending on how your ISP and other routers encountered on the Internet handle your TCP/IP requests, that a MaxMTU setting of 576, often referred to as the "Internet Standard", will in many cases avoid the fragmentation of packets of data and the slow transfer speeds which result. Note that if your ISP is using an MTU lower than 576, (typical with a less efficient SLIP connection, for example), then you will want to lower your MaxMTU setting to match your ISP's. So, check with your ISP to see what he is using for MTU, if you find that the recommended settings are not producing good results for you.


RobustInternetSpeedBooster_RWIN Term

RWIN(Receive Window)

The TCP Receive window size is the amount of receive data (in bytes) that can be buffered at one time on a connection. That is the amount of data the sending host can send before waiting for an acknowledgement and a window update from the receiving host. Matching the receive window to even increments of the MSS increases the percentage of full-sized TCP segments utilized during bulk data transmissions is the MaxMTU ( 40 bytes for TCP and IP headers).

The RWIN default is 8192 bytes rounded up to the nearest MSS increment for the connection. If that isn’t at least 4 times the MSS, then it’s adjusted to 4*MSS, with a max size of 64k.bytes. With widows 95 default MaxMTU of 1500, the default RWIN is rounded to 8760 (1460*4).Performance can be greatly improved by setting RWIN to a lower value such as 4 times your MSS (MTU-40).The trick is to bring it to a value below 8192.Many users have better success with 6,8 or even 10* MSS.
However; manually setting RWIN may decrease performance because it takes the control away from windows, and if the MTU is negotiated to a different value, then the size of the RWIN is no longer a whole integer multiple. Therefore; for adjusting RWIN to be effective you must make sure your MTU is set where it will not renegotiate to a lower value.

Note: If you are experiencing problems such as your browser stopping in the middle of a page, an MTU value of 576 might fix the problem.


RobustInternetSpeedBooster_TTL Term

TTL (Time To Live)

Specifies the default time to live (TTL) for IP packets from Microsoft TCP/IP. It is a field in the Internet Protocol header which indicates how many more hops this packet should be allowed to make before being discarded or returned. This time specifies the maximum number of routers that the packet may be forwarded through on to its destination. That means the maximum number of hops permitted. For example Windows 95 default is 32. However; with our internet today this number should be larger say 128.


RobustInternetSpeedBooster_Session Keep Alive Term

Session Keep alive

You specifies how often to send session keep alive packets on active sessions.
When downloading, this will keep your connection that has stalled from timing out.
Windows default value is 60 minutes, it is recommended to set it to 10 minutes.


RobustInternetSpeedBooster_NDI Cache Term

NDI Cache

Your source routing paths are stored in a cache and NDI Cache is the size of that cache. It has a very large effect on the performance of your TCP connection.
For example, if your MaxMTU is set to 576 or below, it is recommended to set the NDI cache to 16, and if your MaxMTU is greater than 576 then set your NDI Cache to 32.


RobustInternetSpeedBooster_Path MTU Auto Discovery

Path MTU Auto Discovery

This setting is enabled by default. Enabling this setting causes TCP to attempt to discover the Maximum Transmission Unit (MTU or largest packet size) over the path to a remote host. Knowing the Path MTU and limiting the TCP segments to this specific size, the TCP protocol is supposed to be able to eliminate fragmentation of the packets at routers on the communication path that connects networks with different MTUs. In order for this to happen, the server side algorithm implementation has to be known, and also assumes all of the servers on the entire network only run MSFT server software with server- side optimization features accessible from MSFT web-browser client software. However; this is very unlikely. Accordingly; it is not recommended to disable this setting as it would then cause an MTU of 576 bytes to be used for all connections that are not to computers on the local subnet. Therefore; disabling this setting can cause severe performance degradation because fragmentation may not be compensated for.


RobustInternetSpeedBooster_PMTU Black Hole

PMTU Black Hole Detect

Is disabled by default. This specifies whether the stack will be able to detect Maximum Transmission Unit (MTU) routers that do not send back ICMP (Internet Message Protocol) fragmentation-needed messages. With this feature enabled, TCP will try to send segments without the Don’t Fragment bit set if several re-transmissions of a segment go unacknowledged. If the segment is acknowledged as a result, the MTU will be decreased and the Don’t Fragment bit will be set in future packets on the connection.

Enabling black hole detection increases the maximum number of re-transmissions performed for a given segment. Setting this parameter when it is not needed can cause performance degradation. However; if the router is not sending back the ICMP messages, then PMTU Discovery will not work. This can cause even greater performance degradation.


RobustInternetSpeedBooster_MSCPS

MSCPS using HTTP 1.0 & MSCPS using HTTP 1.1

This option is used in order to increase the number of simultaneous downloads from the same web site. For example windows limits connections to a single HTTP 1.0 server to four simultaneous connections. In addition connections to a single HTTP 1.1 server will be limited to two connections.